XenDesktop 4. Not perfect.

I know tons of people will email me or comment saying I am a prick, an idiot and things along these lines. But after using Citrix XenDesktop 4 for a while, I have to give some feedback to tons of people that are probably trying the product the same way I am. That means the small shop willing to go for the free 10 licenses for XenDesktop 4.

First of all some background information here. I have been working with Citrix products for at least 15 years now. Yes, that long. I have seen it all. The good, the bad, the ugly. Citrix is indeed a company capable of great feats and at the same time, bottom crap shit. So I can safely say I am pretty versed on Citrix and its product line up.

On the virtualization frontend, even though I am no VMWare vExpert I have been using their stuff since VMWare Workstation 1.0. Used GSX, ESX, VMWare Server, VMWare Fusion, VMWare Player and so on. Deployed some decent size virtualization environments too (200+ servers). Pretty versed on it and decent knowledge on the underlying components.

Resuming: I am not as stupid as it looks like.

So what have I been trying to achieve? Very simple (and cheap). At home I have a Dell PowerEdge T105 box with 8GB RAM and 2x500GB disks (RAID 1) with dual NICs, connected to a Dell PowerConnect 2824 switch. The T105 runs ESXi 4.X (free version) and has always worked fine. Great product for sure. And yes, I do use memory overcommitment and for my needs it is simply perfect, with no performance issues whatsoever. Before you ask, yes, that is the main reason why a Citrix CTP decided to use VMWare ESXi instead of XenServer. The lack of overcommitment, for ME, is a show stopper. I wrote more about the topic here.

Back to the topic, as we are indeed a small shop, this little guy runs all for us. 2008 DC, 2008 Web, 2008 with Exchange 2007 plus two XP VMs. Actually this post you are reading is hosted on my 2008 Web Server, running under this ESXi box.

So I decided to test something very simple. As I got a freebie last year at BriForum (remember, I am the current champion of the Geek Out show that happens every BriForum) from Wyse (a Windows XPe terminal, notebook form factor) I decided to give it a try as a thin client for a XenDesktop 4 solution (by the way I had SEVERAL issues with the stupid Wyse X90 – probably will post about these later, so buyer, BE AWARE).

Got the free XenDesktop 4 license (good for 10 users) and followed the whole installation guide. Setup another VM on my ESXi (2003 Server with IIS, etc, part of my 2008 AD) and also setup a Windows 7 VM (1GB RAM). The setup could be easier and certain things make no sense whatsoever. But I somehow expected that to be the case coming from Citrix (they are a bunch of smart people that sometimes find some very weird and cumbersome ways of doing things).

Once I had all up and running I faced the first problem: the Windows 7 VM would simply hang after logging in from the DDC Web Interface. Looking at the ESXi console I could see the VM there, up and running but I would not be able to login (when it was shown as available – more on that later). After ranting a little bit on Twitter someone facing the same issue mentioned a problem with the video driver and a possible workaround. Tried that and indeed that issue was fixed.

Great so I thought.

Not too fast there fellas. Once that was fixed now I had to deal with a more serious issue. When I login to the DDC WI, it tries to start my Windows 7 VM but fails and throws an error. I then go to the vSphere console and I can see the VM all good there and I can even logon to it. Once I do that, almost like waking it up from some sort of ‘standby’ then the web interface/DDC works!

I discussed the issue with several other people running a similar setup (small shop with free ESXi) and they all face some sort of issue with XenDesktop 4. Apparently if you use Windows XP, what I have not tried, it works. But that I refuse to do as I left XP for good and more than that, as my customers are all considering a similar Windows 7 approach I must stay with the latest and greatest technology. So I do not care if it works with XP. Citrix does say Windows 7 is supported and I cannot see anywhere saying the free ESXi is not supported as Mr. Joe Shonk mentioned (so I assume it is for this unmanaged desktops case).

The bottom line for me is simple. When it works, XenDesktop 4 is a great product. But there are still issues not only at the core but on other components from what I hear (Provisioning Server issues, XenServer reliability problems and so on) and what amazes me is some of these, like the first one I had, apparently are known issues. If that is the case why not adding a readme file that explains these and the workarounds? Or why not fixing that crap?

I do see the power of XenDesktop and where it can take VDI once it is integrated with XenClient. But for now, Citrix, please let me know what needs to get done to make this work. I am sure several small businesses would jump into the VDI bandwagon with the free 10 licenses everyone can get for XenDesktop 4 but it must work.

If I find a solution or if Citrix decides to take a look at my problem I will let you guys know.

If I disappear after this post you know Citrix got me. For good.

CR

4,135 total views, no views today